MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-1479

CLONE -t:inputCalendar displays year 1900 when an incorrect date is entered

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.9
    • Fix Version/s: 1.1.11
    • Component/s: Calendar
    • Labels:
      None

      Description

      When the user provides an incorrect date value (e.g. "12" when the popupDateFormat is "dd/MM/yyyy") the popup will display year 1900 instead of the current year.

      1. calendar.jpg
        22 kB
        Pavel Blinov
      2. TOMAHAWK-1479.patch
        0.3 kB
        Pavel Blinov

        Issue Links

          Activity

          Leonardo Uribe added a comment -

          Thanks to Pavel Blinov for provide this patch.

          Pavel Blinov added a comment -

          This problem is still reproducible. If you enter something like "10/10" in text box and click calendar button you will see 1900 year in the calendar instead of current year. Looks like the problem is in JavaScript parser (date.js).


            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Pavel Blinov
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development