MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-1438

<t:selectOneRadio> is broken when migrating from 1.1.8 to 1.1.9

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 1.1.9
    • Fix Version/s: None
    • Component/s: selectOneRadio / radio
    • Labels:
      None
    • Environment:
      windows xp, jsf 1.2.6, java 6

      Description

      I migrated from 1.1.8 to 1.1.9 to see if my application would be stable. On one page, <t:selectOneRadio> buttons was not showing up at all. I researched for a bit but couldn't find any solution. I don't think I can afford to test every case for a migration so decided to drop the idea (we have our app in production already).

      I'm unable to give a test case but I can share the code used on the page:

      <t:selectOneRadio id="defaultPhoneType" value="$

      {controller.preferedPhoneType}

      " layout="spread">
      <f:selectItem itemLabel="" itemValue="HOME"/>
      <f:selectItem itemLabel="" itemValue="WORK"/>
      <f:selectItem itemLabel="" itemValue="CELL"/>
      </t:selectOneRadio>

      <!-- somewhere in the same page -->

      <fieldset>
      <legend><span>xyz</span></legend>
      <ul class="fieldRows phoneSet">
      <li class="noteRow">
      Note: One preferred phone number is required
      </li>
      <li class="phoneRow">
      <t:outputLabel value="#

      {dictionary.home}

      #

      {dictionary.phone}

      :" styleClass="phonePrefLabel" />
      <t:radio for="defaultPhoneType" index="0" /> <!-- this doesn't show up on 1.1.9 tomahawk but works in 1.1.8)

      .....
      .....

        Activity

        reverttoconsole created issue -
        Leonardo Uribe added a comment -

        I don't think it is broken. Just look the code:

        <f:selectItem itemLabel="" itemValue="HOME"/>

        If no itemLabel is used, no value will be output on t:radio as label. Try something like this:

        <f:selectItem itemLabel="Some label for HOME value" itemValue="HOME"/>

        The issues fixed on 1.1.9 for this component are: TOMAHAWK-1429, TOMAHAWK-1395 and TOMAHAWK-1393 (duplicate of TOMAHAWK-1371) . Maybe take a look a them could help.

        If no objections I'll close this issue as invalid (no errors detected on test for this component, and the behavior described is expected).

        reverttoconsole added a comment -

        I added a label, there's no difference except that a "label" is now displayed on the page. I'm not sure how you think it's not broken. R

        – Replace the jar to 1.1.8, radiobuttons are present
        – Place 1.1.9 jar – radiobuttons are gone!

        Isn't that proof enough.

        I would like to help you give some test data but I'm afraid I don't know what else you need me to provide apart from the code given above.

        Christian Kaltepoth added a comment -

        I checked this issue but wasn't able to reproduce the problem with the
        described environment (MyFaces Core 1.2.6 + Java6).

        Tomahawk 1.1.8 and 1.1.9 both render the radio buttons correctly
        even with an empty itemLabel.

        There seems to be some other problem in your application that causes
        this behavior. I'm very sorry, but I don't think we can help you
        without a test case that can reproduce this issue.

        Leonardo Uribe added a comment -

        I'll close this one as invalid, because there there is no way to reproduce it, and checking the latest code everything seems to be fine.

        Leonardo Uribe made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Leonardo Uribe [ lu4242 ]
        Resolution Invalid [ 6 ]

          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            reverttoconsole
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development