MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-1359

activeOnViewIds toggleActive does not work properly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.11
    • Component/s: Panel Navigation2
    • Labels:
      None

      Description

      We are using commandNavigation2 with the proprety activeOnViewIds to prevent the menu from collapsing if we use a button to navigate on the next side (instead of the panelNavigation2).
      Unfortunately the property only works if you enter exactly on jsp. If you use more than one jsp, the toggleActive method overwrites the active state for every every jsp present in the activeOnViewIds-property, i.e. the pages a.jsp;b.jsp;c.jsp are in the property and you navigate to b.jsp the else branch in toggleActive sets the activity to false for.a.jsp than works properly for b.jsp but for c.jsp the active state is set to false again.

        Activity

        Mats Andreassen added a comment -

        I just encountered this "bug".

        It seems that this works just the way it should, but you have to use a comma as the separator. The problem is: All documentation I've encountered, including the tagdoc, specifies that semi-colon should be used.

        Leonardo Uribe added a comment -

        Fixed documentation that says semicolon instead comma. Thanks for point the bug on the documentation.


          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Markus Alvermann
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development