MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-1149

panelNavigation2 seems incompatible with Trinidad

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.6
    • Fix Version/s: 1.1.6
    • Component/s: Panel Navigation2
    • Labels:
      None

      Description

      When I enable the trinidad renderer in the face-config.xml the menu doesn't work anymore. I get a javascript error
      Error: clear_menu_5Fform is not defined
      Following is an example of a panelNavigation that works fine, as long as I don't use Trinidad:

      <h:form id="menu_form" styleClass="naked">
      <t:panelNavigation2 id="pn2" styleClass="nav1" layout="list" itemClass="mypage" activeItemClass="selected" openItemClass="selected">
      <t:commandNavigation2 value="index" action="index">
      <t:outputText value="Home" />
      </t:commandNavigation2>
      </t:panelNavigation2>
      </h:form>

      When I use Trinidad I get Javascript errors when clicking on the navigation links and nothing else happens, i.e. no navigation or changing pages.
      When I look in the sourcecode of the generated page the javascript section is indeed missing. When I disable the trinidad renderer again (removing the entry in the application section in the faces-config.xml) the javascript appears in the source of the page again. Somehow the trinidad renderer eliminates the javascript inline sections from the output.

      Tested with Tomahawk 1.1.6 and Trinidad 1.0.3

        Issue Links

          Activity

          Andrew Robinson added a comment -

          I am able to use both fine with Facelets. Try Tomahawk 1.1.7-SNAPSHOT and Trinidad 1.0.3 and see if that helps

          Jan Stövesand added a comment - - edited

          I setup a new server and was not able to reproduce it with Trinidad 1.0.4
          I will close this issue.

          Jan Stövesand added a comment -

          Not reproducable with Trinidad 1.0.4


            People

            • Assignee:
              Unassigned
              Reporter:
              Jan Stövesand
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development