Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.6
    • Fix Version/s: 1.1.7
    • Component/s: Calendar
    • Labels:
      None

      Description

      I tryed to use image Location in the inputCalendar component but it doens't run.
      I developed a method into the class:
      org.apache.myfaces.custom.calendar.HtmlCalendarRenderer ; the method is this:

      protected static String getImagePath(FacesContext facesContext,UIComponent uiComponent){

      String urlImage=HtmlRendererUtils.getImageLocation(uiComponent);
      if(urlImage==null || urlImage.trim().length()==0)

      { urlImage= (JavascriptUtils.encodeString(AddResourceFactory.getInstance(facesContext) .getResourceUri(facesContext, HtmlCalendarRenderer.class, "DB/"))); }


      return urlImage;
      }

      and i call this method in the method getLocalizedLanguageScript when i call:
      setStringVariable(script,popupCalendarVariable +".initData.imgDir",getImagePath(facesContext,uiComponent));

      if i defined a image path i took the images i want, else i took the standard images in the Tomahawk jar.
      It seems run good.

        Issue Links

          Activity

          Enrico De Benetti created issue -
          Enrico De Benetti made changes -
          Field Original Value New Value
          Attachment HtmlCalendarRenderer.java [ 12361962 ]
          Simon Kitching made changes -
          Link This issue is related to TOMAHAWK-689 [ TOMAHAWK-689 ]
          Simon Kitching added a comment -

          Setting the imageLocation attribute on the t:inputCalendar tag works for me with the current trunk, without any patches.

          Please test again. If it still fails for you, post your calendar tag definition and the section of the generated html source that sets up the initData.imgDir variable.

          Simon Kitching added a comment -

          Closing due to no response from original poster.

          Simon Kitching made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Cannot Reproduce [ 5 ]
          Leonardo Uribe made changes -
          Fix Version/s 1.1.7 [ 12313398 ]
          Fix Version/s 1.1.7-SNAPSHOT [ 12312361 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Enrico De Benetti
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development