Uploaded image for project: 'TinkerPop'
  1. TinkerPop
  2. TINKERPOP-2572

Upgrade dependencies to fix security vulnerabilities

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Invalid
    • Affects Version/s: 3.5.0
    • Fix Version/s: 3.5.0
    • Component/s: gremlint
    • Labels:
      None

      Description

      A few of Gremlint's indirect dependencies have vulnerabilities listed in the GitHub Advisory Database.

      Specifically the following should be done:

      • Upgrade ws to version 7.4.6 or later (moderate severity) [1].
      • Upgrade lodash to version 4.17.21 or later (high severity) [2].
      • Upgrade hosted-git-info to version 2.8.9 or later (moderate severity) [3].
      • Upgrade y18n to version 4.0.1 or later (high severity) [4].
      • Upgrade node-notifier to version 8.0.1 or later (moderate severity) [5].

      [1] https://github.com/advisories/GHSA-6fc8-4gx4-v693
      [2] https://github.com/advisories/GHSA-35jh-r3h4-6jhm
      [3] https://github.com/advisories/GHSA-43f8-2h32-f4cj
      [4] https://github.com/advisories/GHSA-c4w7-xm78-47vh
      [5] https://github.com/advisories/GHSA-5fw9-fq32-wv5p

        Attachments

          Activity

            People

            • Assignee:
              oyvindsabo Øyvind Sæbø
              Reporter:
              oyvindsabo Øyvind Sæbø
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 24h
                24h
                Remaining:
                Remaining Estimate - 24h
                24h
                Logged:
                Time Spent - Not Specified
                Not Specified