Tiles
  1. Tiles
  2. TILES-418

Infinite loop in rendering when including result of another action/servlet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 2.1.2
    • Fix Version/s: None
    • Component/s: tiles-servlet
    • Labels:
      None
    • Environment:

      Tomcat 6, osx, java5

    • Flags:
      Important

      Description

      An infinite loop occurs resulting in a stack overflow when you try an include the results of another action/servlet where both results are of a tiles type. I have included an eclipse project which shows this - just deploy via WTP for quick testing. More info below.

      Index.jsp which is a tiles definition -

      <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
      <head>
      <title>Index</title>
      <s:head />
      </head>
      <body>
      Test index
      <s:action name="helloWorld" executeResult="true" /> <------------ CAUSES PROBLEM
      </body>
      </html>

      The s:action tag causes an infinite loop to occur. Note that replacing the s:action tag with c:import or jsp:include gives the same results so it is not the tag itself. This works fine with tile 2.0.X. Stacktrace and project code is attached.

      1. struts2-tiles-test.zip
        37 kB
        Alvin Singh
      2. stacktrace.log.rtf.zip
        16 kB
        Alvin Singh

        Activity

        Hide
        Alvin Singh added a comment -

        Project test code to replicate issue + stacktrace

        Show
        Alvin Singh added a comment - Project test code to replicate issue + stacktrace
        Hide
        Antonio Petrelli added a comment -

        Struts 2/Tiles 2 plugin is not compatible to Tiles 2.1. Please report to the Struts 2 team.

        Show
        Antonio Petrelli added a comment - Struts 2/Tiles 2 plugin is not compatible to Tiles 2.1. Please report to the Struts 2 team.
        Hide
        Viktor Hedefalk added a comment -

        I get the same problem with Spring 3.1.1 and tiles 2.2.2 so I don't think it really has anything to do with Struts? I'll attach my stack-loop.

        Show
        Viktor Hedefalk added a comment - I get the same problem with Spring 3.1.1 and tiles 2.2.2 so I don't think it really has anything to do with Struts? I'll attach my stack-loop.

          People

          • Assignee:
            Unassigned
            Reporter:
            Alvin Singh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development