Tika
  1. Tika
  2. TIKA-833

POI Daily beta6 as of 12/27 breaks ExcelParserTest.testExcelParserFormatting()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Component/s: parser
    • Labels:

      Description

      Attn Nick:

      Changes made to POI(v1221126) for POI-52349 causes the ExcelParserTest.testExcelParserFormatting() junit test case to go out to lunch within POI's DataFormatter.FractionFormat(). Specifically within the nested for loops at line 1000. These nested loops both have extremely high values that cause the test case to hang for an extremely long duration during the new OfficeParser().parse(input, handler, metadata, context); call at line 73. This appears to happen due to the Custom Date value in the test file not being identified as a date.

      I'm not sure if the proper resolution lies in modifying TIKA's test case or if a new bug needs to be opened on POI's side, but I wanted to bring this issue to light.

      Regards,

      Jeremy

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          1d 23h 1 Jeremy Anderson 29/Dec/11 13:47
          Resolved Resolved Reopened Reopened
          2h 28m 1 Jeremy Anderson 29/Dec/11 16:15
          Reopened Reopened Closed Closed
          55s 1 Jeremy Anderson 29/Dec/11 16:16
          Jukka Zitting added a comment -

          Thanks, Jeremy!

          Jeremy Anderson made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Fix Version/s 1.1 [ 12318849 ]
          Resolution Not A Problem [ 8 ]
          Jeremy Anderson added a comment -

          Issue lies in base POI and is now fixed

          Jeremy Anderson made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Jeremy Anderson added a comment -

          re-opening to change the status to keep out of release notes.

          Thanks Jukka, still getting the hang of JIRA's various options and their trickle down effects.

          Jukka Zitting added a comment -

          It's good that we monitor changes in POI and make sure that Tika works properly with the latest versions, but until the changes in POI have been released and relevant dependency in Tika trunk updated, this is not an bug in Tika and IMHO shouldn't be tracked as one.

          The POI bug #52389 is more appropriate, and rather than resolving this issue as fixed for Tika 1.1 I think we should resolve this as Invalid or Duplicate (of POI bug #52389) to keep the 1.1 release notes clean.

          Jeremy Anderson made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 1.1 [ 12318849 ]
          Resolution Fixed [ 1 ]
          Jeremy Anderson added a comment -

          Fixed in POI as of r1225098.

          Jeremy Anderson made changes -
          Comment [ Fixed in POI as of r1225098. ]
          Jeremy Anderson added a comment -

          Added POI-52389 pacth for the issue. Root cause appears to be logic added around line 355 for the DataFormatter that causes the FractionFormat() to be called on all formats containing /. Added a hack to ignore making this call when the format string contains 'AM/PM' or 'am/pm'.

          Jeremy Anderson made changes -
          Description Attn Nick:

          Changes made to POI(v1221126) for POI-52349 causes the ExcelParserTest.testExcelParserFormatting() junit test case to go out to lunch within POI's DataFormatter.FractionFormat(). Specifically within the nested for loops at line 1000. These nested loops both have extremely high values that cause the test case to hang for an extremely long duration during the new OfficeParser().parse(input, handler, metadata, context); call at line 73.

          I'm not sure if the proper resolution lies in modifying TIKA's test case or if a new bug needs to be opened on POI's side, but I wanted to bring this issue to light.

          Regards,

          Jeremy
          Attn Nick:

          Changes made to POI(v1221126) for POI-52349 causes the ExcelParserTest.testExcelParserFormatting() junit test case to go out to lunch within POI's DataFormatter.FractionFormat(). Specifically within the nested for loops at line 1000. These nested loops both have extremely high values that cause the test case to hang for an extremely long duration during the new OfficeParser().parse(input, handler, metadata, context); call at line 73. This appears to happen due to the Custom Date value in the test file not being identified as a date.

          I'm not sure if the proper resolution lies in modifying TIKA's test case or if a new bug needs to be opened on POI's side, but I wanted to bring this issue to light.

          Regards,

          Jeremy
          Jeremy Anderson made changes -
          Field Original Value New Value
          Link This issue blocks TIKA-700 [ TIKA-700 ]
          Jeremy Anderson created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Jeremy Anderson
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development