Tika
  1. Tika
  2. TIKA-677

Installing Tika 0.9 using Maven fails tests

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.9
    • Fix Version/s: None
    • Component/s: general
    • Labels:
    • Environment:

      Debian Squeeze 64 bit

      Description

      ===== Build failure screen scrape starts =====
      root@CW8vDS:~# export JAVA_HOME=/usr/lib/jvm/java-6-openjdk; \
      export PATH=$JAVA_HOME/bin:$PATH; \
      export M2_HOME=/usr/local/apache-maven/apache-maven-3.0.2; \
      export M2=$M2_HOME/bin; \
      export PATH=$M2:$PATH
      root@CW8vDS:~# ver=0.9; dir=/opt/apache/tika; mkdir -p $dir \
      && cp /root/Repository/apache-tika-$ver-src.zip $dir \
      && cd $dir \
      && unzip apache-tika-$ver-src.zip \
      && cd apache-tika-$ver \
      && time mvn install
      Archive: apache-tika-0.9-src.zip
      replace apache-tika-0.9/KEYS? [y]es, [n]o, [A]ll, [N]one, [r]ename: A
      [much snip]
      Results :

      Failed tests:
      testBMP(org.apache.tika.parser.image.ImageParserTest)
      testJPEG(org.apache.tika.parser.image.ImageParserTest)
      testPNG(org.apache.tika.parser.image.ImageParserTest)
      [snip]
      ===== Build failure screen scrape starts =====

      ===== tika-parsers/target/surefire-reports/org.apache.tika.parser.image.ImageParserTest.txt begins =====
      -------------------------------------------------------------------------------
      Test set: org.apache.tika.parser.image.ImageParserTest
      -------------------------------------------------------------------------------
      Tests run: 4, Failures: 3, Errors: 0, Skipped: 0, Time elapsed: 1.032 sec <<< FAILURE!
      testBMP(org.apache.tika.parser.image.ImageParserTest) Time elapsed: 0.597 sec <<< FAILURE!
      junit.framework.ComparisonFailure: expected:<... > but was:<...>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tika.parser.image.ImageParserTest.testBMP(ImageParserTest.java:40)

      testJPEG(org.apache.tika.parser.image.ImageParserTest) Time elapsed: 0.377 sec <<< FAILURE!
      junit.framework.ComparisonFailure: expected:<Licensed to the Apache Software Foundation (ASF) under one or more contributor license agreements. See the NOTICE file distributed with this work for additional information regarding copyright ownership.> but was:<null>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tika.parser.image.ImageParserTest.testJPEG(ImageParserTest.java:104)

      testPNG(org.apache.tika.parser.image.ImageParserTest) Time elapsed: 0.033 sec <<< FAILURE!
      junit.framework.ComparisonFailure: expected:<true> but was:<TRUE>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tika.parser.image.ImageParserTest.testPNG(ImageParserTest.java:129)
      ===== tika-parsers/target/surefire-reports/org.apache.tika.parser.image.ImageParserTest.txt ends =====

      ===== tika-parsers/target/surefire-reports/TEST-org.apache.tika.parser.image.ImageParserTest.xml begins =====
      <?xml version="1.0" encoding="UTF-8" ?>
      <testsuite failures="3" time="1.029" errors="0" skipped="0" tests="4" name="org.apache.tika.parser.image.ImageParserTest">
      <properties>
      <property name="java.runtime.name" value="OpenJDK Runtime Environment"/>
      <property name="sun.boot.library.path" value="/usr/lib/jvm/java-6-openjdk/jre/lib/amd64"/>
      <property name="java.vm.version" value="14.0-b16"/>
      <property name="java.vm.vendor" value="Sun Microsystems Inc."/>
      <property name="java.vendor.url" value="http://java.sun.com/"/>
      <property name="path.separator" value=":"/>
      <property name="java.vm.name" value="OpenJDK 64-Bit Server VM"/>
      <property name="file.encoding.pkg" value="sun.io"/>
      <property name="user.country" value="GB"/>
      <property name="sun.java.launcher" value="SUN_STANDARD"/>
      <property name="sun.os.patch.level" value="unknown"/>
      <property name="java.vm.specification.name" value="Java Virtual Machine Specification"/>
      <property name="user.dir" value="/opt/apache/tika/apache-tika-0.9/tika-parsers"/>
      <property name="java.runtime.version" value="1.6.0_18-b18"/>
      <property name="java.awt.graphicsenv" value="sun.awt.X11GraphicsEnvironment"/>
      <property name="basedir" value="/opt/apache/tika/apache-tika-0.9/tika-parsers"/>
      <property name="java.endorsed.dirs" value="/usr/lib/jvm/java-6-openjdk/jre/lib/endorsed"/>
      <property name="os.arch" value="amd64"/>
      <property name="surefire.real.class.path" value="/tmp/surefirebooter1051167902616068794.jar"/>
      <property name="javax.accessibility.assistive_technologies" value="org.GNOME.Accessibility.JavaBridge"/>
      <property name="java.io.tmpdir" value="/tmp"/>
      <property name="line.separator" value="
      "/>
      <property name="java.vm.specification.vendor" value="Sun Microsystems Inc."/>
      <property name="os.name" value="Linux"/>
      <property name="sun.jnu.encoding" value="UTF-8"/>
      <property name="java.library.path" value="/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/server:/usr/lib/jvm/java-6-openjdk/jre/lib/amd64:/usr/lib/jvm/java-6-openjdk/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib/jni:/lib:/usr/lib"/>
      <property name="surefire.test.class.path" value="/opt/apache/tika/apache-tika-0.9/tika-parsers/target/test-classes:/opt/apache/tika/apache-tika-0.9/tika-parsers/target/classes:/opt/apache/tika/apache-tika-0.9/tika-core/target/tika-core-0.9.jar:/root/.m2/repository/edu/ucar/netcdf/4.2-min/netcdf-4.2-min.jar:/root/.m2/repository/org/slf4j/slf4j-api/1.5.6/slf4j-api-1.5.6.jar:/root/.m2/repository/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar:/root/.m2/repository/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar:/root/.m2/repository/commons-codec/commons-codec/1.2/commons-codec-1.2.jar:/root/.m2/repository/org/apache/james/apache-mime4j/0.6/apache-mime4j-0.6.jar:/root/.m2/repository/org/apache/commons/commons-compress/1.1/commons-compress-1.1.jar:/root/.m2/repository/org/apache/pdfbox/pdfbox/1.4.0/pdfbox-1.4.0.jar:/root/.m2/repository/org/apache/pdfbox/fontbox/1.4.0/fontbox-1.4.0.jar:/root/.m2/repository/org/apache/pdfbox/jempbox/1.4.0/jempbox-1.4.0.jar:/root/.m2/repository/org/bouncycastle/bcmail-jdk15/1.45/bcmail-jdk15-1.45.jar:/root/.m2/repository/org/bouncycastle/bcprov-jdk15/1.45/bcprov-jdk15-1.45.jar:/root/.m2/repository/org/apache/poi/poi/3.7/poi-3.7.jar:/root/.m2/repository/org/apache/poi/poi-scratchpad/3.7/poi-scratchpad-3.7.jar:/root/.m2/repository/org/apache/poi/poi-ooxml/3.7/poi-ooxml-3.7.jar:/root/.m2/repository/org/apache/poi/poi-ooxml-schemas/3.7/poi-ooxml-schemas-3.7.jar:/root/.m2/repository/org/apache/xmlbeans/xmlbeans/2.3.0/xmlbeans-2.3.0.jar:/root/.m2/repository/dom4j/dom4j/1.6.1/dom4j-1.6.1.jar:/root/.m2/repository/org/apache/geronimo/specs/geronimo-stax-api_1.0_spec/1.0.1/geronimo-stax-api_1.0_spec-1.0.1.jar:/root/.m2/repository/org/ccil/cowan/tagsoup/tagsoup/1.2/tagsoup-1.2.jar:/root/.m2/repository/asm/asm/3.1/asm-3.1.jar:/root/.m2/repository/com/drewnoakes/metadata-extractor/2.4.0-beta-1/metadata-extractor-2.4.0-beta-1.jar:/root/.m2/repository/de/l3s/boilerpipe/boilerpipe/1.1.0/boilerpipe-1.1.0.jar:/root/.m2/repository/rome/rome/0.9/rome-0.9.jar:/root/.m2/repository/jdom/jdom/1.0/jdom-1.0.jar:/root/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar:/root/.m2/repository/org/mockito/mockito-core/1.7/mockito-core-1.7.jar:/root/.m2/repository/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar:/root/.m2/repository/org/objenesis/objenesis/1.0/objenesis-1.0.jar:/root/.m2/repository/org/slf4j/slf4j-log4j12/1.5.6/slf4j-log4j12-1.5.6.jar:/root/.m2/repository/log4j/log4j/1.2.14/log4j-1.2.14.jar:"/>
      <property name="java.specification.name" value="Java Platform API Specification"/>
      <property name="java.class.version" value="50.0"/>
      <property name="sun.management.compiler" value="HotSpot 64-Bit Server Compiler"/>
      <property name="os.version" value="2.6.32-5-amd64"/>
      <property name="user.home" value="/root"/>
      <property name="user.timezone" value="Asia/Kolkata"/>
      <property name="java.awt.printerjob" value="sun.print.PSPrinterJob"/>
      <property name="java.specification.version" value="1.6"/>
      <property name="file.encoding" value="UTF-8"/>
      <property name="user.name" value="root"/>
      <property name="java.class.path" value="/opt/apache/tika/apache-tika-0.9/tika-parsers/target/test-classes:/opt/apache/tika/apache-tika-0.9/tika-parsers/target/classes:/opt/apache/tika/apache-tika-0.9/tika-core/target/tika-core-0.9.jar:/root/.m2/repository/edu/ucar/netcdf/4.2-min/netcdf-4.2-min.jar:/root/.m2/repository/org/slf4j/slf4j-api/1.5.6/slf4j-api-1.5.6.jar:/root/.m2/repository/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar:/root/.m2/repository/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar:/root/.m2/repository/commons-codec/commons-codec/1.2/commons-codec-1.2.jar:/root/.m2/repository/org/apache/james/apache-mime4j/0.6/apache-mime4j-0.6.jar:/root/.m2/repository/org/apache/commons/commons-compress/1.1/commons-compress-1.1.jar:/root/.m2/repository/org/apache/pdfbox/pdfbox/1.4.0/pdfbox-1.4.0.jar:/root/.m2/repository/org/apache/pdfbox/fontbox/1.4.0/fontbox-1.4.0.jar:/root/.m2/repository/org/apache/pdfbox/jempbox/1.4.0/jempbox-1.4.0.jar:/root/.m2/repository/org/bouncycastle/bcmail-jdk15/1.45/bcmail-jdk15-1.45.jar:/root/.m2/repository/org/bouncycastle/bcprov-jdk15/1.45/bcprov-jdk15-1.45.jar:/root/.m2/repository/org/apache/poi/poi/3.7/poi-3.7.jar:/root/.m2/repository/org/apache/poi/poi-scratchpad/3.7/poi-scratchpad-3.7.jar:/root/.m2/repository/org/apache/poi/poi-ooxml/3.7/poi-ooxml-3.7.jar:/root/.m2/repository/org/apache/poi/poi-ooxml-schemas/3.7/poi-ooxml-schemas-3.7.jar:/root/.m2/repository/org/apache/xmlbeans/xmlbeans/2.3.0/xmlbeans-2.3.0.jar:/root/.m2/repository/dom4j/dom4j/1.6.1/dom4j-1.6.1.jar:/root/.m2/repository/org/apache/geronimo/specs/geronimo-stax-api_1.0_spec/1.0.1/geronimo-stax-api_1.0_spec-1.0.1.jar:/root/.m2/repository/org/ccil/cowan/tagsoup/tagsoup/1.2/tagsoup-1.2.jar:/root/.m2/repository/asm/asm/3.1/asm-3.1.jar:/root/.m2/repository/com/drewnoakes/metadata-extractor/2.4.0-beta-1/metadata-extractor-2.4.0-beta-1.jar:/root/.m2/repository/de/l3s/boilerpipe/boilerpipe/1.1.0/boilerpipe-1.1.0.jar:/root/.m2/repository/rome/rome/0.9/rome-0.9.jar:/root/.m2/repository/jdom/jdom/1.0/jdom-1.0.jar:/root/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar:/root/.m2/repository/org/mockito/mockito-core/1.7/mockito-core-1.7.jar:/root/.m2/repository/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar:/root/.m2/repository/org/objenesis/objenesis/1.0/objenesis-1.0.jar:/root/.m2/repository/org/slf4j/slf4j-log4j12/1.5.6/slf4j-log4j12-1.5.6.jar:/root/.m2/repository/log4j/log4j/1.2.14/log4j-1.2.14.jar:"/>
      <property name="java.vm.specification.version" value="1.0"/>
      <property name="sun.arch.data.model" value="64"/>
      <property name="java.home" value="/usr/lib/jvm/java-6-openjdk/jre"/>
      <property name="java.specification.vendor" value="Sun Microsystems Inc."/>
      <property name="user.language" value="en"/>
      <property name="java.vm.info" value="mixed mode"/>
      <property name="java.version" value="1.6.0_18"/>
      <property name="java.ext.dirs" value="/usr/lib/jvm/java-6-openjdk/jre/lib/ext:/usr/java/packages/lib/ext"/>
      <property name="sun.boot.class.path" value="/usr/lib/jvm/java-6-openjdk/jre/lib/resources.jar:/usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar:/usr/lib/jvm/java-6-openjdk/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-6-openjdk/jre/lib/jsse.jar:/usr/lib/jvm/java-6-openjdk/jre/lib/jce.jar:/usr/lib/jvm/java-6-openjdk/jre/lib/charsets.jar:/usr/lib/jvm/java-6-openjdk/jre/lib/rhino.jar:/usr/lib/jvm/java-6-openjdk/jre/classes"/>
      <property name="java.vendor" value="Sun Microsystems Inc."/>
      <property name="localRepository" value="/root/.m2/repository"/>
      <property name="file.separator" value="/"/>
      <property name="java.vendor.url.bug" value="http://java.sun.com/cgi-bin/bugreport.cgi"/>
      <property name="sun.cpu.endian" value="little"/>
      <property name="sun.io.unicode.encoding" value="UnicodeLittle"/>
      <property name="sun.cpu.isalist" value=""/>
      </properties>
      <testcase time="0.595" classname="org.apache.tika.parser.image.ImageParserTest" name="testBMP">
      <failure message="expected:<... > but was:<...>" type="junit.framework.ComparisonFailure">junit.framework.ComparisonFailure: expected:<... > but was:<...>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tika.parser.image.ImageParserTest.testBMP(ImageParserTest.java:40)
      </failure>
      </testcase>
      <testcase time="0.017" classname="org.apache.tika.parser.image.ImageParserTest" name="testGIF"/>
      <testcase time="0.377" classname="org.apache.tika.parser.image.ImageParserTest" name="testJPEG">
      <failure message="expected:<Licensed to the Apache Software Foundation (ASF) under one or more contributor license agreements. See the NOTICE file distributed with this work for additional information regarding copyright ownership.> but was:<null>" type="junit.framework.ComparisonFailure">junit.framework.ComparisonFailure: expected:<Licensed to the Apache Software Foundation (ASF) under one or more contributor license agreements. See the NOTICE file distributed with this work for additional information regarding copyright ownership.> but was:<null>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tika.parser.image.ImageParserTest.testJPEG(ImageParserTest.java:104)
      </failure>
      </testcase>
      <testcase time="0.032" classname="org.apache.tika.parser.image.ImageParserTest" name="testPNG">
      <failure message="expected:<true> but was:<TRUE>" type="junit.framework.ComparisonFailure">junit.framework.ComparisonFailure: expected:<true> but was:<TRUE>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tika.parser.image.ImageParserTest.testPNG(ImageParserTest.java:129)
      </failure>
      </testcase>
      ===== tika-parsers/target/surefire-reports/TEST-org.apache.tika.parser.image.ImageParserTest.xml ends =====

        Activity

        Jukka Zitting added a comment -

        Resolving as a duplicate of TIKA-551.

        Charles added a comment -

        Thanks Maxim

        Sorry – having worked around the problem by installing Tika 0.9 directly from from http://repo2.maven.org/maven2/org/apache/tika/tika-app/0.9/tika-app-0.9.jar, this problem has assumed a low priority so we are unlikely to try as you suggest any time soon.

        Best

        Charles

        Maxim Valyanskiy added a comment -

        I think it is a problem in ImageIO of your JDK. Try to update it to latest version. See also TIKA-551


          People

          • Assignee:
            Unassigned
            Reporter:
            Charles
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development