Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: parser
    • Labels:
      None

      Description

      Here is an initial implementation of a SWF Parser which uses JavaSWF and has been adapted from A. Bialecki's implementation for Nutch.
      The main differences with the implementation for Nutch is that we use the latest version of JavaSWF and do not try to extract text from the actions or structured URLs. As usual URLs can be obtained from the text extracted using ParserPostProcessor.
      JavaSWF has changed quite a bit since the Nutch integration and I wanted to keep this initial port nice and simple. It should be possible to extract the URLs from the actions using JavaSWF's API, I think this is what they did in Heritrix.

      1. test.swf
        50 kB
        Julien Nioche
      2. TIKA-337.patch
        12 kB
        Julien Nioche

        Issue Links

          Activity

          Julien Nioche added a comment -

          patch for SWF parser

          Jukka Zitting added a comment -

          Resolving as a duplicate of the earlier issue TIKA-147. I'll add a comment there pointing to your patch.

          Before applying the patch we'll need to get the JavaSWF library uploaded to Maven central. I sent a message to the JavaSWF support list about this.

          Julien Nioche added a comment -

          test file for the swf parser


            People

            • Assignee:
              Jukka Zitting
              Reporter:
              Julien Nioche
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development