Uploaded image for project: 'Tika'
  1. Tika
  2. TIKA-2890

Critical security vulnerability in dependencies

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.21
    • Fix Version/s: 1.23
    • Component/s: parser
    • Labels:
      None

      Description

      The parser dependency jackson-databind:2.9.8 has a critical vulnerability as per:

      https://ossindex.sonatype.org/vuln/5bbadb96-496f-4534-a513-7a6396f54029

      This should be bumped to >2.9.9 to resolve this vulnerability.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                slowtokyo Kyle DuPont
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1h
                  1h
                  Remaining:
                  Remaining Estimate - 1h
                  1h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified