Uploaded image for project: 'Tika'
  1. Tika
  2. TIKA-2728

Update poi dependency from 3.17 to 4.0.0 (For Java 9/10 compatibility)

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.18
    • Fix Version/s: None
    • Component/s: parser
    • Environment:

      Java 9 / Java 10

      Description

      The poi project has a bug in version 3.17 when running on Java 9/10:

      WARNING: Illegal reflective access by org.apache.poi.util.DocumentHelper (file:/usr/local/tomcat/webapps/ROOT/WEB-INF/lib/poi-ooxml-3.17.jar) to method com.sun.org.apache.xerces.internal.util.SecurityManager.setEntityExpansionLimit(int)
      WARNING: Please consider reporting this to the maintainers of org.apache.poi.util.DocumentHelper
      WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
      WARNING: All illegal access operations will be denied in a future release

      See https://bz.apache.org/bugzilla/show_bug.cgi?id=61564 for more details.

       

      There was never a 3.17.1 release, but there has been a 4.0.0 release.  Suggest updating.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                TigerC10 Ian Cervantez
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: