Uploaded image for project: 'Tika'
  1. Tika
  2. TIKA-217

TikaConfig fails when a parser can't be loaded due to an Error

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.3
    • Fix Version/s: 0.4
    • Component/s: config
    • Labels:
      None

      Description

      When running in Java 1.4, some of the Parser classes can't be loaded due to dependencies (POI, etc.) that require Java 5 or higher. These cases throw UnsupportedClassVersionErrors or somilar Throwables that aren't caught by the current "catch (Exception e)" clause. We should catch all Throwables there.

        Attachments

          Activity

            People

            • Assignee:
              jukkaz Jukka Zitting
              Reporter:
              jukkaz Jukka Zitting
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: