Thrift
  1. Thrift
  2. THRIFT-956

Python module's version meta-data should be updated

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.5
    • Fix Version/s: 0.9
    • Component/s: Python - Library
    • Labels:
      None

      Description

      There has been a lot of changes in Thrift Python module recently but the version number in the setup.py has been kept in 0.1 for more than a year. This should be updated to some meaningful number as upgrade will be smoother with a proper version. A proper version would also make it easy to let users know which version of Python module they're using.

      Meta-data in fb303's setup.py has not maintained since the first commit, too. This may as well be also updated.

        Issue Links

          Activity

          Gavin made changes -
          Link This issue depends upon THRIFT-6 [ THRIFT-6 ]
          Gavin made changes -
          Link This issue depends on THRIFT-6 [ THRIFT-6 ]
          Jake Farrell made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Jake Farrell [ jfarrell ]
          Fix Version/s 0.9 [ 12316294 ]
          Resolution Fixed [ 1 ]
          Roger Meier made changes -
          Field Original Value New Value
          Link This issue depends on THRIFT-6 [ THRIFT-6 ]
          Akira Kitada created issue -

            People

            • Assignee:
              Jake Farrell
              Reporter:
              Akira Kitada
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development