Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-5312

The Ruby compilation configuration in the .gemspec file is modified to be compatible with later bundler versions.

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.15.0
    • Component/s: Ruby - Library
    • Labels:
      None

      Description

      If use the version laster to build the ruby lib will fail by a error like this:

      /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb10: warning: constant Gem::ConfigMap is deprecated.
      

      Want to be compatible with the new bundler version.

      From the content in the link, there is no problem.
      semver

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                zeshuai007 Zezeng Wang
                Reporter:
                zeshuai007 Zezeng Wang
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h