Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-5259

Fix "Transport endpoint is not connected " error when running lua test server accepts a connection

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 0.13.0
    • None
    • Lua - Library
    • None

    Description

      I ran the lua tests as follows and all failed:

      1. Edit tests.json, add the lua server configuration
      2. test.py --server lua --client lua

      After checking the log, it was found that the problem occurred when the server accepted the connection:

      ===============================================================================
      lua: ../../lib/lua/Thrift.lua:40: Transport endpoint is not connected
      stack traceback:
      [C]: in function 'error'
      ../../lib/lua/Thrift.lua:40: in function 'terror'
      ../../lib/lua/TSocket.lua:129: in method 'accept'
      ../../lib/lua/TServer.lua:132: in method 'serve'
      test_basic_server.lua:141: in function 'testBasicServer'
      test_basic_server.lua:145: in main chunk
      [C]: in ?
      ===============================================================================

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            2er0 zero

            Dates

              Created:
              Updated:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 50m
                50m

                Slack

                  Issue deployment