Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-5205

Tag prior releases with "v" prefix for compatibility with go.mod

    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 0.10.0, 0.11.0
    • Fix Version/s: None
    • Component/s: Go - Library
    • Labels:
      None

      Description

      Thrift 0.13.0 uses the tag "v0.13.0", while prior releases do not have the "v" prefix. Is it possible to add an additional tag "v0.10.0", "v0.11.0", etc for older releases so that Go modules works correctly with them, see https://github.com/golang/go/issues/32945

       

      We have some projects that use older versions and can't update due to the breaking changes where ctx was added as a parameter, so need to use old versions, but would still like to use go.mod.

       

      Adding additional tags (the old ones should still be valid) would help unblock usage of Go modules.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              prashantv Prashant V
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: