Thrift
  1. Thrift
  2. THRIFT-484

Ability to use a slice of a buffer instead of a direct byte[] for binary fields

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.4
    • Labels:
      None

      Description

      The HBase folks who are considering using Thrift for their internal and external RPC have suggested that it would be a useful performance enhancement to be able to use a subslice of a byte array as the value of a binary field, without first doing a new byte array copy. Done correctly, this would mean that the data could be copied once from when it is read in from the socket to when it is written out as part of HBase's internal datastructures.

      This enhancement seems like it could boost the performance of things in Hadoop, as well, so it could be a really nice option to investigate.

        Issue Links

          Activity

          Bryan Duxbury created issue -
          Bryan Duxbury made changes -
          Field Original Value New Value
          Link This issue relates to HBASE-794 [ HBASE-794 ]
          Todd Lipcon made changes -
          Fix Version/s 0.3 [ 12314451 ]
          Fix Version/s 0.2 [ 12313769 ]
          Bryan Duxbury made changes -
          Fix Version/s 0.4 [ 12314960 ]
          Fix Version/s 0.3 [ 12314451 ]
          Bryan Duxbury made changes -
          Assignee Bryan Duxbury [ bryanduxbury ]
          Bryan Duxbury added a comment -

          Duplicate of THRIFT-830.

          Bryan Duxbury made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          449d 3h 21m 1 Bryan Duxbury 28/Jul/10 21:25

            People

            • Assignee:
              Bryan Duxbury
              Reporter:
              Bryan Duxbury
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development