Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-4732

increase cmake minimal required version and cleanup cmake scripts

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build Process
    • Labels:
      None

      Description

      In order to use modern cmake syntax to cleanup building scripts and add shared library support on Windows by using [windows_export_all_symbol

      So I think it is a good idea to increase cmake minimal required version.May be 3.10 is a good alternative version?

       

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              cyy yuanyuan chen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 40m
                40m