Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-4232

./configure does bad ant version check

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.11.0
    • Component/s: Build Process
    • Labels:
      None
    • Environment:

      OSX 10.12.5, running ant 1.10.1

      Description

      On line 18869 of the configure script, it checks that the ant version is >= 1.7. It uses some kind of string comparison. This breaks for my current ant version (1.10). It seems to think that 1.10 is not >= 1.7. I think this is because it's comparing strings without taking into account what the strings actually mean. Something like this might be a possible patch:

      https://stackoverflow.com/questions/16989598/bash-comparing-version-numbers

      This should be fixed because it means that people with new ant versions can't build the java thrift library.

      Also it should be checked to see if other parts of the configure process are using these kinds of faulty version checks.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jking3 James E. King III
                Reporter:
                dwoodwardgb David Woodward
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 3h
                  3h
                  Remaining:
                  Remaining Estimate - 3h
                  3h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified