Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-4009

Use @implementer instead of implements in TTwisted.py

    XMLWordPrintableJSON

    Details

    • Flags:
      Patch

      Description

      As per zope.interface 4.0.0 changelog

      • Deprecate the “class advice” APIs from zope.interface.declarations: implements, implementsOnly, and classProvides. In their place, prefer the equivalent class decorators: @implementer, @implementer_only, and @provider. Code which uses the deprecated APIs will not work as expected under Py3k.

      https://pypi.python.org/pypi/zope.interface

      PR incoming, patch is simply output of zope-2to3 -wn lib/py/src/transport/TTwisted.py

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ciarancourtney Ciaran Courtney
                Reporter:
                ciarancourtney Ciaran Courtney
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: