Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-3946

Java 1.5 compatibility broken for binary fields (java5 option)

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.3
    • Fix Version/s: 0.11.0
    • Component/s: Java - Compiler
    • Labels:
    • Patch Info:
      Patch Available
    • Flags:
      Patch

      Description

      For binary fields, even with the java5 option (--gen java:java5), generated code uses "Arrays.copyOf", which is only available in Java 1.6+.

        Attachments

          Activity

            People

            • Assignee:
              phil_hamer Philip Hamer
              Reporter:
              phil_hamer Philip Hamer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: