Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-3890

Error with gem extension while installing Thrift

    XMLWordPrintableJSON

    Details

    • Type: Question
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Ruby - Library
    • Labels:
      None
    • Environment:

      Ubuntu Trusty 14

      Description

      I am building and installing Apache Thrift from source. When I run make, I get the following error about Gem native. How can I deal with this gem native extension error?

      `Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

      /usr/bin/ruby1.9.1 extconf.rb
      /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file – mkmf (LoadError)
      from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
      from extconf.rb:2:in `<main>'

      Gem files will remain installed in /tmp/bundler20160731-25561-wpjc2k/eventmachine-1.2.0.1/gems/eventmachine-1.2.0.1 for inspection.
      Results logged to /tmp/bundler20160731-25561-wpjc2k/eventmachine-1.2.0.1/gems/eventmachine-1.2.0.1/ext/gem_make.out
      An error occurred while installing eventmachine (1.2.0.1), and Bundler cannot continue.
      Make sure that `gem install eventmachine -v '1.2.0.1'` succeeds before bundling.`

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              davenso Dave
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: