Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-3856

update debian package deependencies

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 0.9.3
    • 0.10.0
    • Build Process
    • None
    • Debian, Ubuntu

    • Patch Available

    Description

      Thrift has incomplete debian package and too old now.
      mono-gmcs and libmono-*1.0-cil are no more exist in supported distributions on both Ubuntu and Debian.
      There is no PHP5 package on Ubuntu Xenial, so I added PHP7 packages.
      (Precise supports ,but we could not compile the cpp library on it.)
      I have some points to talk about:
      ・php7.0 doesn't have complete compatibility for php5.
      ・cutting off java-sdk. This is a virtual package, so some build tools mistake this package not being installed even if being installed.

      Attachments

        Issue Links

          Activity

            People

              matyapiro31 Akira Nakagawa
              matyapiro31 Akira Nakagawa
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: