Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-2183

gem install fails on zsh

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.9.1
    • Fix Version/s: 0.9.2
    • Component/s: Ruby - Library
    • Labels:
      None
    • Environment:

      zsh on linux

    • Patch Info:
      Patch Available

      Description

      Zsh fails to process the glob in the gem install command. This results in the cryptic error message:

      ERROR: Could not find a valid gem 'thrift-*.gem' (>= 0) in any repository

      Fix is attached.

        Attachments

          Activity

            People

            • Assignee:
              roger Roger Meier
              Reporter:
              cout Paul Brannan

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment