Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-2082

Executing "gmake clean" is broken

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      FreeBSD-9.1-RELEASE

    • Patch Info:
      Patch Available

      Description

      Executing "gmake clean" doesn't work, because of the following error:

      username@hostname[43] gmake clean
      Making clean in compiler/cpp
      gmake[1]: Entering directory `/usr/home/username/thrift/thrift-git/compiler/cpp'
      rm -f thrift
      rm -rf .libs _libs
      rm -f thriftl.cc thrifty.cc thrifty.h thrifty.hh version.h windows/version.h
      echo '#include "thrifty.h"' > compiler/cpp/thrifty.hh
      cannot create compiler/cpp/thrifty.hh: No such file or directory
      gmake[1]: *** [clean-local] Error 2
      gmake[1]: Leaving directory `/usr/home/username/thrift/thrift-git/compiler/cpp'
      gmake: *** [clean-recursive] Error 1
      Exit 2
      username@hostname[44]

      The fix is trivial: file compiler/cpp/Makefile.am needs to be edited
      and the bogus "compiler/cpp/" prefix removed, because the "echo ..."
      command is executed in the local directory.
      See attached patch. Don't forget to run "./bootstrap.sh" and "./configure"
      after the patch is applied.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              pavlin Pavlin Radoslavov

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 10m
                10m
                Remaining:
                Remaining Estimate - 10m
                10m
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Issue deployment