Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-1773

Python library should run on python 2.4

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.9.1
    • Component/s: Python - Library
    • Labels:
      None

      Description

      As of 0.9, the Python code seems to require Python >= 2.6 (eg using new syntax not available in 2.4). Since many people still run Thrift-based apps on RHEL5, which includes only 2.4, we should avoid this dependency.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tlipcon Todd Lipcon
                Reporter:
                tlipcon Todd Lipcon
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: