Thrift
  1. Thrift
  2. THRIFT-1674

Update Thrift D library to be compatible with 2.060

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: D - Library
    • Labels:
    • Environment:

      non-Windows

    • Patch Info:
      Patch Available

      Description

      D support was added before the latest D 2.060 release (via THRIFT-1500). Some things have changed in 2.060. Specifically, when core.stdc.errno.getErrno is accessed here, it throws an error because it was made private here.

      I'm still testing with other items on non-Windows setups, but I might submit a patch to fix this soon.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        8d 7h 37m 1 Jake Farrell 18/Aug/12 04:32
        Hudson added a comment -

        Integrated in Thrift #517 (See https://builds.apache.org/job/Thrift/517/)
        Thrift-1674:Update Thrift D library to be compatible with 2.060
        Client: d
        Patch: David Nadlinger

        Updated D lib for 2.060. (Revision 1374507)

        Result = FAILURE

        Jake Farrell made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 0.9 [ 12316294 ]
        Resolution Fixed [ 1 ]
        Jake Farrell added a comment -

        Committed

        David Nadlinger made changes -
        Labels patch
        Assignee David Nadlinger [ klickverbot ]
        Patch Info Patch Available [ 10042 ]
        David Nadlinger added a comment -

        Sorry, I had the changes lying around locally for some time, but apparently I forgot to send them off while trying to make sure that DMD 2.060 wouldn't be released with any of the genuine regressions the Thrift test suite uncovered.

        As I don't have SVN access, somebody please commit the patches. Apart from the hastily written commit messages, they should be fine to go in as-is. With them applied, the test suite should also pass with DMD 2.060 on Linux and OS X.

        Chad Retz made changes -
        Field Original Value New Value
        Description D support was added before the latest D 2.060 release (via THRIFT-1500). Some things have changed in 2.060. Specifically, when core.stdc.errno.getErrno is accessed [here|https://github.com/apache/thrift/blob/b95b0ffa720ffdebd829861ed420d10deab6c852/lib/d/src/thrift/internal/socket.d#L74], it throws an error because of it was made private [here|https://github.com/D-Programming-Language/druntime/commit/901e81d58429756017fbf6c42158148e7872c8fa#L3R25].

        I'm still testing with other items on non-Windows setups, but I might submit a patch to fix this soon.
        D support was added before the latest D 2.060 release (via THRIFT-1500). Some things have changed in 2.060. Specifically, when core.stdc.errno.getErrno is accessed [here|https://github.com/apache/thrift/blob/b95b0ffa720ffdebd829861ed420d10deab6c852/lib/d/src/thrift/internal/socket.d#L74], it throws an error because it was made private [here|https://github.com/D-Programming-Language/druntime/commit/901e81d58429756017fbf6c42158148e7872c8fa#L3R25].

        I'm still testing with other items on non-Windows setups, but I might submit a patch to fix this soon.
        Chad Retz created issue -

          People

          • Assignee:
            David Nadlinger
            Reporter:
            Chad Retz
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development