Thrift
  1. Thrift
  2. THRIFT-1602

PHP C Extension is not Compatible with PHP 5.4

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: PHP - Library
    • Labels:
      None

      Description

      When running make with php 5.4, you'll get:

      ...thrift/ext/thrift_protocol/php_thrift_protocol.cpp:95:8: error: 'function_entry' does not name a type

      This is caused by function_entry being replaced by zend_function_entry https://bugs.php.net/bug.php?id=60016

        Activity

        Jake Farrell added a comment -

        Duplicates THRIFT-1577


          People

          • Assignee:
            Jake Farrell
            Reporter:
            Tyler Hobbs
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development