Thrift
  1. Thrift
  2. THRIFT-158

Some of the C# runtime library files say Copyright (C) 2007 imeem, inc. <http://www.imeem.com> All rights reserved.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.1
    • Component/s: C# - Library
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      Some of the C# library files contain Thrift software license terms. E.g.:
      http://svn.apache.org/repos/asf/incubator/thrift/trunk/lib/csharp/src/TProcessor.cs

      Others contain a closed license copyright notice. E.g.:
      http://svn.apache.org/repos/asf/incubator/thrift/trunk/lib/csharp/src/Transport/TTransport.cs

      // Copyright (C) 2007 imeem, inc. <http://www.imeem.com>
      // All rights reserved.

      Here's the list of files that contain the closed licensing terms:
      lib/csharp/src/Transport/TServerSocket.cs
      lib/csharp/src/Transport/TServerTransport.cs
      lib/csharp/src/Transport/TSocket.cs
      lib/csharp/src/Transport/TStreamTransport.cs
      lib/csharp/src/Transport/TTransport.cs
      lib/csharp/src/Transport/TTransportException.cs
      lib/csharp/src/Transport/TTransportFactory.cs

      1. thrift-158-lib-cocoa.patch
        23 kB
        Andrew McGeachie
      2. license.patch
        21 kB
        Will Palmeri
      3. thrift-158-csharp-asf-license.patch
        40 kB
        Michael Greene

        Issue Links

          Activity

          Kevin Clark added a comment -

          Pushed in r756311

          Michael Greene added a comment -

          This patch adds the ASF license header to all of the C# files in lib/csharp

          Michael Greene added a comment -

          No, I do not think this should be committed. Since Will signed and sent a release form, and has provided this patch, we can replace the imeem headers. However, I think it would be best to replace them with the appropriate headers, per the URI above. I will submit a patch in a little bit.

          Kevin Clark added a comment -

          Do I need to commit this? Sorry, I thought someone was watching C#.

          Michael Greene added a comment -

          Thanks for the patch. Although we haven't standardized on all of what will be in the header, the ASF is actually really clear on what needs to be included in the header: http://www.apache.org/legal/src-headers.html

          For example, http://svn.apache.org/repos/asf/incubator/thrift/trunk/lib/csharp/src/Collections/THashSet.cs includes this header.

          Will Palmeri added a comment -

          Here's an svn patch from head to replace all the imeem copyright and author references with a reference to the Apache License. It seems we still haven't standardized on a file header, so I went with this simple text lifted from the ruby README:

          //
          // Thrift is distributed under the Apache Software License.
          // Please see the included LICENSE file.
          //

          Regardless of what is chosen in the future, I agree it's a good idea to remove the "All copyrights reserved" language. And for the record, I signed and sent a software release form to Apache over a year ago .

          -Will

          Greg Stein added a comment -

          Hmm? The pages that I referenced in a comment above seem pretty non-ambiguous.

          As for what falls below that header... sure. That could take some discussion.

          fwiw, there is no Software Grant on file right now. I just checked, and am following up on that.

          Michael Greene added a comment -

          I fully agree, of course, that everything needs to be cleaned.

          We need a few things, as I see it, that have delayed getting this done:

          • a standardization of exactly what should be allowed in the header. The ASF is a little ambiguous about this – there is a required header but we need consensus that we are going to pursue removing all other header information outside of code functionality and code comments
          • to make sure all existing attributed authors have a Software Grant on file or that the files were contributed using the checkbox on JIRA, which I think is true but I for one don't have any proof
          • a committer to get behind this – we have 3 or 4 active committers, and since this is a very filechange-oriented but not code-oriented activity, someone's going to need to spearhead it.
          Greg Stein added a comment -

          You're effectively exposing the problem of issue-based work. These issues are trying to compartmentalize the work, but that just isn't the case here.

          everything needs the Apache header. all the code needs to remove author tags. all the Facebook copyrights need to be removed (I'm assuming we have the Software Grant on file).

          The simple answer is: stop using these dang issues, and just go commit some fixes. It's been seven months already.

          Michael Greene added a comment -

          If the Cocoa ticket is a duplicate of this C# ticket, it should be generalized to include all of the libraries. Every one of them has some files in conflict with the resolution of this issue. Besides imeem, many of the files include Facebook copyrights. Most have author attribution.

          Also, how does this then relate to the newly-created THRIFT-294 ?

          Andrew McGeachie added a comment -

          This patch adds the apache license header to the lib cocoa source files.

          Greg Stein added a comment -

          Oh. Another comment: we should have a software grant from imeem on file, or the author who added that code should have an ICLA on file. If we cannot get explicit permission from imeem, then we must delete their files from source control.

          This issue should be a BLOCKER. We cannot release or graduate without fixing this. (I don't have karma to edit the issue)

          Greg Stein added a comment -

          Every file that be distributed must follow the guidelines as specified in:
          http://www.apache.org/dev/apply-license.html

          and Apache's general policies on headers are detailed here:
          http://www.apache.org/legal/src-headers.html

          Dave Engberg added a comment -

          I assume the intent was to have them all be like TProcessor.cs, or like (e.g.)
          http://svn.apache.org/repos/asf/incubator/thrift/trunk/lib/java/src/com/facebook/thrift/TProcessor.java

          The problem isn't the copyright, it's the "all rights reserved". IANAL, but I think the files should either state the open source license terms explicitly or reference them to specify the conditions under which they may be used.

          Bryan Duxbury added a comment -

          Apache mandates a common header that includes a notice about the Apache Software License. We need to do a sweep and add this header EVERYWHERE.

          Michael Greene added a comment -

          What should they say? References to the developer.facebook.com website are also common, should they be changed? Does Apache mandate or have guidelines on these specifics?


            People

            • Assignee:
              Michael Greene
              Reporter:
              Dave Engberg
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development