Thrift
  1. Thrift
  2. THRIFT-1519

Thirft Build Failure referencing rb_intern2 symbol

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: Ruby - Library
    • Labels:
    • Environment:

      Description

      This is an output of the rake command from build. The warnings while bother some do not appear to be the issue.

        • Invoke default (first_time)
        • Invoke gem (first_time)
        • Invoke spec (first_time)
        • Invoke gen-rb (first_time)
        • Invoke gen-rb:spec (first_time)
        • Execute gen-rb:spec
          ../../compiler/cpp/thrift --gen rb -o /opt/Scribes/thrift-0.8.0/lib/rb/spec /opt/Scribes/thrift-0.8.0/lib/rb/spec/ThriftSpec.thrift
        • Invoke gen-rb:benchmark (first_time)
        • Execute gen-rb:benchmark
          ../../compiler/cpp/thrift --gen rb -o /opt/Scribes/thrift-0.8.0/lib/rb/benchmark /opt/Scribes/thrift-0.8.0/lib/rb/benchmark/Benchmark.thrift
        • Invoke gen-rb:debug_proto (first_time)
        • Execute gen-rb:debug_proto
          mkdir -p test/debug_proto
          ../../compiler/cpp/thrift --gen rb -o test/debug_proto ../../test/DebugProtoTest.thrift
          [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:41] 64-bit constant "10000000000" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:173] 64-bit constant "1099511627775" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "4294967295" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "1099511627775" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "281474976710655" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "72057594037927935" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "4294967295" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "1099511627775" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "281474976710655" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "72057594037927935" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:201] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:208] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:355] No field key specified for field1, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:356] No field key specified for field2, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:357] No field key specified for field3, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:358] No field key specified for field4, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:359] No field key specified for field5, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:360] No field key specified for field6, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:361] No field key specified for field7, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:362] No field key specified for field8, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:363] No field key specified for field9, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:364] No field key specified for field10, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:365] No field key specified for field11, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:366] No field key specified for field12, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:41] 64-bit constant "10000000000" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:173] 64-bit constant "1099511627775" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "4294967295" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "1099511627775" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "281474976710655" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "72057594037927935" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:183] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "4294967295" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "1099511627775" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "281474976710655" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "72057594037927935" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:192] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:201] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:208] 64-bit constant "9223372036854775807" may not work in all languages.

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:355] No field key specified for field1, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:356] No field key specified for field2, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:357] No field key specified for field3, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:358] No field key specified for field4, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:359] No field key specified for field5, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:360] No field key specified for field6, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:361] No field key specified for field7, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:362] No field key specified for field8, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:363] No field key specified for field9, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:364] No field key specified for field10, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:365] No field key specified for field11, resulting protocol may have conflicts or not be backwards compatible!

      [WARNING:/opt/Scribes/thrift-0.8.0/test/DebugProtoTest.thrift:366] No field key specified for field12, resulting protocol may have conflicts or not be backwards compatible!

        • Execute gen-rb
        • Invoke build_ext (first_time)
        • Invoke gen-rb
        • Execute build_ext
          ruby extconf.rb
          checking for strlcpy() in string.h... yes
          creating Makefile
          make
          make: Nothing to be done for `all'.
        • Invoke realspec (first_time)
        • Execute realspec
          ld.so.1: ruby: fatal: relocation error: file /opt/Scribes/thrift-0.8.0/lib/rb/spec/../ext/thrift_native.so: symbol rb_intern2: referenced symbol not found
          Killed
          rake aborted!
          Command /usr/local/bin/ruby -I"lib" "/usr/local/lib/ruby/gems/1.8/gems/rspec-1.3.2/bin/spec" "spec/base_protocol_spec.rb" "spec/base_transport_spec.rb" "spec/binary_protocol_accelerated_spec.rb" "spec/binary_protocol_spec.rb" "spec/client_spec.rb" "spec/compact_protocol_spec.rb" "spec/exception_spec.rb" "spec/http_client_spec.rb" "spec/mongrel_http_server_spec.rb" "spec/nonblocking_server_spec.rb" "spec/processor_spec.rb" "spec/serializer_spec.rb" "spec/server_socket_spec.rb" "spec/server_spec.rb" "spec/socket_spec.rb" "spec/struct_spec.rb" "spec/types_spec.rb" "spec/union_spec.rb" "spec/unix_socket_spec.rb" --color failed
          /usr/local/lib/ruby/gems/1.8/gems/rspec-1.3.2/lib/spec/rake/spectask.rb:177:in `define'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/file_utils_ext.rb:60:in `verbose'
          /usr/local/lib/ruby/gems/1.8/gems/rspec-1.3.2/lib/spec/rake/spectask.rb:153:in `define'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `call'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `execute'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `each'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `invoke_with_call_chain'
          /usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
          /usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
          /usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
          /usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:116:in `invoke_task'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `each'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:88:in `top_level'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:66:in `run'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
          /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:33
          /usr/local/bin/rake:19:in `load'
          /usr/local/bin/rake:19
          Tasks: TOP => default => gem => spec => realspec

        Activity

        Jake Farrell made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 0.9 [ 12316294 ]
        Resolution Cannot Reproduce [ 5 ]
        Jake Farrell added a comment -

        Ilya, are you still having this issue? I can not reproduce and I have tried several operating systems. On OS X 10.7.3 with default ruby 1.8.7 and showing no issues

        gem build thrift.gemspec
        Successfully built RubyGem
        Name: thrift
        Version: 0.9.0.1
        File: thrift-0.9.0.1.gem

        Ilya Maykov added a comment -

        Having the same issue with ruby 1.8.7-p352 installed with rbenv on Mac OS X 10.7.3. Does anyone have a workaround?

        Thomas Wroblewski made changes -
        Comment [ Hey Jake,

                So progress has been made. It doesn’t error out however the ruby compile does hang. I let it run for 12 hours since our last email chain and it did not make any progress. I've enclosed the output of the make so you can see the spot where it hangs. Please ignore where it says rake aborted. That is my cancelling the command. Please let me know what you think. Thanks.

                Best Regards,

                Thomas



        ]
        Thomas Wroblewski made changes -
        Attachment make.out [ 12515379 ]
        Jake Farrell added a comment -

        Looks like the libruby shared library is missing or isnt in the search paths for the extension

        Thomas Wroblewski added a comment -

        No, I got ruby from sunfreeware as it is a solaris box. Is this an RVM issue? Also, I have bundler 1.0.22.

        Jake Farrell added a comment -

        tested with ruby 1.8.7 using bundler 1.0.18, ext/thrift_native shared library created successfully (tested on os x and linux). are you using rvm?

        Jake Farrell made changes -
        Assignee Jake Farrell [ jfarrell ]
        Thomas Wroblewski made changes -
        Field Original Value New Value
        Priority Major [ 3 ] Critical [ 2 ]
        Thomas Wroblewski created issue -

          People

          • Assignee:
            Jake Farrell
            Reporter:
            Thomas Wroblewski
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development