Thrift
  1. Thrift
  2. THRIFT-1327

Fix Spec Suite under Ruby-1.8.7 (works for MRI Ruby-1.9.2)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: Ruby - Library
    • Labels:
      None
    • Environment:

      Ruby-1.8.7 (MRI/JRuby/Rubinius)

      Description

      The Spec suite is currently exhibiting issues, when run under Ruby 1.8.7. Ruby 1.8.7 interpreters MRI, JRuby, and Rubinius should all be tested and verified as working.

      In addition, it would make sense to use something like RVM, on the CI server, so we can easily test compatibility across different Ruby versions and interpreters.

      This does not affect Ruby-1.9.2 MRI, and has not been tested under JRuby's 1.9 mode. CI should run JRuby twice, under both the 1.8 and 1.9 compatibility-modes.

        Activity

        Scott Gonyea created issue -
        Scott Gonyea made changes -
        Field Original Value New Value
        Summary Fix RSpec suite under Ruby-1.8.7 Fix Spec suite under Ruby-1.8.7
        Scott Gonyea made changes -
        Summary Fix Spec suite under Ruby-1.8.7 Fix Spec Suite under Ruby-1.8.7 (works for MRI Ruby-1.9.2)
        Description The Spec suite is currently exhibiting issues, when run under Ruby 1.8.7. Ruby 1.8.7 interpreters MRI, JRuby, and Rubinius should all be tested and verified as working.

        In addition, it would make sense to use something like RVM, on the CI server, so we can easily test compatibility across different Ruby versions and interpreters.
        The Spec suite is currently exhibiting issues, when run under Ruby 1.8.7. Ruby 1.8.7 interpreters MRI, JRuby, and Rubinius should all be tested and verified as working.

        In addition, it would make sense to use something like RVM, on the CI server, so we can easily test compatibility across different Ruby versions and interpreters.

        This does not affect Ruby-1.9.2 MRI, and has not been tested under JRuby's 1.9 mode. CI should run JRuby twice, under both the 1.8 and 1.9 compatibility-modes.
        Jake Farrell made changes -
        Fix Version/s 0.8 [ 12316293 ]
        Jake Farrell made changes -
        Fix Version/s 0.8 [ 12316293 ]
        Jake Farrell made changes -
        Assignee Roger Meier [ roger.meier ]
        Fix Version/s 0.8 [ 12316293 ]
        Jake Farrell made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Roger Meier [ roger.meier ] Jake Farrell [ jfarrell ]
        Fix Version/s 0.9 [ 12316294 ]
        Resolution Won't Fix [ 2 ]

          People

          • Assignee:
            Jake Farrell
            Reporter:
            Scott Gonyea
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development