Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-1204

Ruby autogenerated files should require 'thrift' gem

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.6.1
    • Fix Version/s: 0.9
    • Component/s: Ruby - Compiler
    • Labels:
      None
    • Environment:

      All

    • Patch Info:
      Patch Available

      Description

      The gen-rb files currently don't require the thrift gem. This means that the user of such a file must explicitly require 'thrift' in his code before requiring a gen-rb file, which can be a bit annoying (especially when debugging / experimenting in IRB). I propose that we change the compiler to add the require at the top of every gen-rb file.

      Patch coming shortly.

        Attachments

          Activity

            People

            • Assignee:
              ilyam Ilya Maykov
              Reporter:
              ilyam Ilya Maykov
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: