Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6, 0.7
    • Fix Version/s: None
    • Component/s: C++ - Compiler
    • Labels:
    • Patch Info:
      Patch Available

      Description

      steps:
      ./bootstrap.sh
      ./configure
      make
      sudo make install
      cd contrib/fb303
      ./bootstrap.sh
      ./configure
      make

      Fails with error:

      gen-cpp/fb303_types.cpp:11: error: 'fb_status' is not a class or namespace
      gen-cpp/fb303_types.cpp:12: error: 'fb_status' is not a class or namespace
      gen-cpp/fb303_types.cpp:13: error: 'fb_status' is not a class or namespace
      gen-cpp/fb303_types.cpp:14: error: 'fb_status' is not a class or namespace
      gen-cpp/fb303_types.cpp:15: error: 'fb_status' is not a class or namespace
      gen-cpp/fb303_types.cpp:16: error: 'fb_status' is not a class or namespace
      make[3]: *** [fb303_types.o] Error 1
      make[3]: Leaving directory `/home/sudhir/workspace/scribe/thrift-apache/contrib/fb303/cpp'
      make[2]: *** [all] Error 2
      make[2]: Leaving directory `/home/sudhir/workspace/scribe/thrift-apache/contrib/fb303/cpp'
      make[1]: *** [all-recursive] Error 1
      make[1]: Leaving directory `/home/sudhir/workspace/scribe/thrift-apache/contrib/fb303'
      make: *** [all] Error 2

      1. commit-55acf75
        0.9 kB
        Sudhir Jorwekar

        Activity

        Hudson added a comment -

        Integrated in Thrift #128 (See https://hudson.apache.org/hudson/job/Thrift/128/)

        Roger Meier added a comment -

        committed! Thanks all for verification.

        Nevo Hed added a comment -

        worked for us too, thanks

        Louis-Philippe Gauthier added a comment -

        Patch seems to work.

        Tyler Peterson added a comment -

        Built thrift 0.5.0 and fb303. Problem does NOT occur in that version.

        Tyler Peterson added a comment -

        Upgraded to Ubuntu 10.10, reverted the patch to Trunk HEAD, rebuilt. Build failed again as described in this bug.

        Tyler Peterson added a comment -

        This defect hit me today on Ubuntu 10.04. I first tried building the latest release, 0.6.0. Then built from trunk (r1086298). Got the err described above both times. I patched compiler/cpp/src/generate/t_cpp_generator.cc as shown in the patch. After rebuilding thrift I found that I could now successfully build fb303. I can't really say if the patch is right, but applying it did allow my build of fb303 to succeed, both in the 0.6.0 release and HEAD of trunk (as of this morning).

        Roger Meier added a comment -

        I could not reproduce your error on trunk:

        URL: https://svn.apache.org/repos/asf/thrift/trunk
        Revision: 1076790

        What version are you using?

        Raymond Dabu added a comment -

        hi! how does this solve the issue above? i also encountered it while compiling fb303. does it need to be placed in some directory and run it? please help. thanks.

        Sudhir Jorwekar added a comment -

        THRIFT-1060. Fixes fb303 compile issue and other pure enum related compile errors.


          People

          • Assignee:
            Unassigned
            Reporter:
            Sudhir Jorwekar
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development