Texen
  1. Texen
  2. TEXEN-10

Handling of file.contents suffix is flawed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1
    • Labels:
      None

      Description

      The code to process the suffix "file.contents" does not check that there is a "." before the suffix; it unconditionally removes the previous character.

      So for example:

      statusfile.contents=STATUS

      will be accepted, and the file contents stored in the context as $statu - this is presumably not what was intended.

        Activity

        Will Glass-Husain made changes -
        Fix Version/s 1.1 [ 12312817 ]
        Will Glass-Husain made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Will Glass-Husain added a comment -

        Thanks, Sebb. Patch applied.

        Sebb made changes -
        Field Original Value New Value
        Attachment patch.txt [ 12360398 ]
        Sebb created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Sebb
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development