Uploaded image for project: 'Tephra'
  1. Tephra
  2. TEPHRA-239

Null pointer exception in TransactionStateCache

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0-incubating
    • Component/s: None
    • Labels:
      None

      Description

      In our Phoenix test runs we have seen the following NPE in TransactionStateCache.

      2017-07-19 18:57:56,136 INFO  [tx-state-refresh] org.apache.tephra.coprocessor.TransactionStateCache$1(144): Exiting thread tx-state-refresh
      2017-07-19 18:57:56,138 ERROR [TransactionStateCache STOPPING] org.apache.zookeeper.server.NIOServerCnxnFactory$1(44): Thread Thread[TransactionStateCache STOPPING,5,main] died
      java.lang.NullPointerException
      	at org.apache.tephra.coprocessor.TransactionStateCache.shutDown(TransactionStateCache.java:85)
      	at com.google.common.util.concurrent.AbstractIdleService$1$2.run(AbstractIdleService.java:57)
      	at java.lang.Thread.run(Thread.java:745)
      2017-07-19 18:57:56,138 WARN  [RS_CLOSE_REGION-pietas:52618-2] org.apache.tephra.coprocessor.ReferenceCountedSupplier(89): Exception while trying to stop Service TransactionStateCache.
      com.google.common.util.concurrent.UncheckedExecutionException: java.lang.NullPointerException
      	at com.google.common.util.concurrent.Futures.wrapAndThrowUnchecked(Futures.java:1015)
      	at com.google.common.util.concurrent.Futures.getUnchecked(Futures.java:1001)
      	at com.google.common.util.concurrent.AbstractService.stopAndWait(AbstractService.java:225)
      	at com.google.common.util.concurrent.AbstractIdleService.stopAndWait(AbstractIdleService.java:122)
      	at org.apache.tephra.coprocessor.ReferenceCountedSupplier.release(ReferenceCountedSupplier.java:86)
      	at org.apache.tephra.coprocessor.TransactionStateCacheSupplier.release(TransactionStateCacheSupplier.java:61)
      	at org.apache.tephra.hbase.coprocessor.TransactionProcessor.stop(TransactionProcessor.java:182)
      	at org.apache.phoenix.coprocessor.DelegateRegionObserver.stop(DelegateRegionObserver.java:82)
      	at org.apache.hadoop.hbase.coprocessor.CoprocessorHost$Environment.shutdown(CoprocessorHost.java:433)
      	at org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost$RegionEnvironment.shutdown(RegionCoprocessorHost.java:152)
      	at org.apache.hadoop.hbase.coprocessor.CoprocessorHost.shutdown(CoprocessorHost.java:274)
      	at org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost$5.postEnvCall(RegionCoprocessorHost.java:512)
      	at org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost.execOperation(RegionCoprocessorHost.java:1761)
      	at org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost.postClose(RegionCoprocessorHost.java:505)
      	at org.apache.hadoop.hbase.regionserver.HRegion.doClose(HRegion.java:1542)
      	at org.apache.hadoop.hbase.regionserver.HRegion.close(HRegion.java:1381)
      	at org.apache.hadoop.hbase.regionserver.handler.CloseRegionHandler.process(CloseRegionHandler.java:138)
      	at org.apache.hadoop.hbase.executor.EventHandler.run(EventHandler.java:129)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NullPointerException
      	at org.apache.tephra.coprocessor.TransactionStateCache.shutDown(TransactionStateCache.java:85)
      	at com.google.common.util.concurrent.AbstractIdleService$1$2.run(AbstractIdleService.java:57)
      	... 1 more
      2017-07-19 18:57:56,139 DEBUG [RS_CLOSE_REGION-pietas:52618-2] org.apache.hadoop.hbase.coprocessor.CoprocessorHost(272): Stop coprocessor org.apache.phoenix.coprocessor.ServerCachingEndpointImpl
      2017-07-19 18:57:56,139 DEBUG [RS_CLOSE_REGION-pietas:52618-2] org.apache.hadoop.hbase.coprocessor.CoprocessorHost(272): Stop coprocessor org.apache.phoenix.coprocessor.GroupedAggregateRegionObserver
      2017-07-19 18:
      

      Test run: https://builds.apache.org/job/Phoenix-master/1699/testReport/junit/org.apache.phoenix.end2end/ViewIT/testNonSaltedUpdatableViewWithIndex_transactional___false_/

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/incubator-tephra/pull/46

          githubbot ASF GitHub Bot added a comment -

          GitHub user gokulavasan opened a pull request:

          https://github.com/apache/incubator-tephra/pull/46

          TEPHRA-239 Fix NPE by waiting for the service to startup

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/gokulavasan/incubator-tephra feature/tephra-239

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/incubator-tephra/pull/46.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #46


          commit 67bf7846e3928c1197db4287d317cb8a44c78d19
          Author: Gokul Gunasekaran <gokul@cask.co>
          Date: 2017-08-17T17:38:21Z

          TEPHRA-239 Fix NPE by waiting for the service to startup



            People

            • Assignee:
              gokulavasan Gokul Gunasekaran
              Reporter:
              samarthjain Samarth Jain
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development