Uploaded image for project: 'Tephra'
  1. Tephra
  2. TEPHRA-222

Fix InvalidListPruneTest#testRecordCompactionState flaky test

    Details

    • Type: Test
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.11.0-incubating
    • Fix Version/s: 0.12.0-incubating
    • Component/s: None
    • Labels:
      None

      Description

      Async flush thread is making the InvalidListPruneTest flaky.

      testRecordCompactionState(org.apache.tephra.hbase.txprune.InvalidListPruneTest) Time elapsed: 17.396 sec <<< FAILURE!
      java.lang.AssertionError: expected:<50> but was:<-1>
      at org.junit.Assert.fail(Assert.java:88)
      at org.junit.Assert.failNotEquals(Assert.java:743)
      at org.junit.Assert.assertEquals(Assert.java:118)
      at org.junit.Assert.assertEquals(Assert.java:555)
      at org.junit.Assert.assertEquals(Assert.java:542)
      at

        Issue Links

          Activity

          poornachandra Poorna Chandra added a comment -

          This is a duplicate of TEPHRA-220


            People

            • Assignee:
              poornachandra Poorna Chandra
              Reporter:
              gokulavasan Gokul Gunasekaran
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development