Uploaded image for project: 'Apache Taverna'
  1. Apache Taverna
  2. TAVERNA-1061

t2flow does not work with T3 server

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: To Do
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: server 3.1.0
    • Fix Version/s: None
    • Component/s: Taverna Server
    • Labels:
      None

      Description

      Sending a t2flow to a tomcat hosted T3 server results in a "failed to build workflow run worker" and a report that the file is using the wrong namespace when it does not appear to be.

      eg curl -k -X POST -d @Fetch_today_s_xkcd_comic-v1.t2flow --header "Content-Type:application/vnd.taverna.t2flow+xml" http://taverna:taverna@192.168.0.5:8080/taverna-server/rest/runs
      where the workflow file is https://www.myexperiment.org/workflows/824.html
      I have also tried with a t1 workflow using content-type "application/xml" which also failed though I'm not sure whether the server is supposed to support that or not.

        Attachments

        1. tavmob_fail.txt
          35 kB
          Ian William Dunlop

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ianwdunlop Ian William Dunlop
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: