Tapestry
  1. Tapestry
  2. TAPESTRY-954

Session lost when PageLInk inside a form

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0
    • Fix Version/s: 4.1.2
    • Component/s: Framework
    • Labels:
      None

      Description

      If you insert a PageLink inside a form no url in the generated page includes a jsessionid as it should. So if a browser does not support cookies, the session is lost if you click on any link that is on the page generated on form submission.

      remarks:

      • the cookie used to track the session is rightly sent to the client
      • other type of links have not been tested (ExternalLInk etc...)

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        304d 5h 6m 1 Jesse Kuhnert 19/Mar/07 00:54
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12567738 ] jira [ 12590866 ]
        Mark Thomas made changes -
        Workflow jira [ 12372122 ] Default workflow, editable Closed status [ 12567738 ]
        Jesse Kuhnert made changes -
        Assignee Jesse Kuhnert [ jkuhnert ]
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Jesse Kuhnert added a comment -

        Just tested some links inside forms with cookies disabled and jsession appears to be getting embedded correctly. Assuming that it was fixed at some point.

        Jesse Kuhnert made changes -
        Field Original Value New Value
        Fix Version/s 4.1.2 [ 12312202 ]
        Oscar Picasso created issue -

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Oscar Picasso
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development