Tapestry
  1. Tapestry
  2. TAPESTRY-930

Tapestry Documentation Errata (Render Block)

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: unspecified
    • Fix Version/s: 4.1.1
    • Component/s: Documentation
    • Labels:
      None

      Description

      Hey Geoff,

      I was wondering if you could perhaps update the documentation listed
      at this URL :
      http://jakarta.apache.org/tapestry/tapestry/ComponentReference/RenderBlock.html

      If you look take a look at TabPanel.java, then you'll see that the method call,

      // Begin Code
      (String) getBlockNames().get(0);
      // End Code

      should rather be changed to (String)getBlockIds().get(0);

      Also, in TabTest.html, blockNames should be changed to blockIds.

      I presume that this was the correct implementation when using T3, but
      it no longers work with T4, perhaps a note/warning could be added to
      make us aware of this change.

      Thanks in advance,

      – Izak

        Activity

        Geoff Longman added a comment -

        Hi Izak,

        Thanks for the note. I have no idea when I will have time to make a change but luckily one can get any Tapestry committer's attention by adding a bug in JIRA.

        Which I have done for you: http://issues.apache.org/jira/browse/TAPESTRY-930

        Cheers,

        Geoff

        Brian K. Wallace added a comment -

        This is a duplicate of TAPESTRY-927 which is fixed pending next release.

        Geoff Longman added a comment -

        Well it appears this is a dupe of http://issues.apache.org/jira/browse/TAPESTRY-927
        Don't seem to have th karma to mark it so.


          People

          • Assignee:
            Unassigned
            Reporter:
            Geoff Longman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development