Tapestry
  1. Tapestry
  2. TAPESTRY-895

White space is stripped between localization directives.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.1.1
    • Component/s: Framework
    • Labels:
      None

      Description

      When two localization directives are separated by white space and the first directive consists of a start-end tag pair, the white space between the directives is removed. This does not occur if the first directive is an empty (self-closing) tag.

      For example, the following template markup:

      <span key="hello-key">Hello</span> <span key="world-key">World</span><br/>
      <span key="hello-key"/> <span key="world-key"/><br/>
      <span key="hello-key">Hello</span> <span key="world-key"/><br/>
      <span key="hello-key"/> <span key="world-key">World</span><br/>
      <span key="hello-key"></span> <span key="world-key"></span><br/>

      Is rendered like this:

      HelloWorld<br/>
      Hello World<br/>
      HelloWorld<br/>
      Hello World<br/>
      HelloWorld<br/>

        Activity

        Andreas Andreou added a comment -

        This is a duplicate of TAPESTRY-256 and TAPESTRY-359 and it is supposed to be resolved in 4.0

        Jesse Kuhnert added a comment -

        I guess the IBM java 1.5 may be be behaving like the Sun Java 1.4,
        which adds the extra spaces before the closing tags.

        Of course another way to look at it is that Sun Java 1.5 removes the
        spaces, which the others leave in...

        Samples:
        <hr noshade="noshade" size="1" /> ! sun 1.4 and IBM as below
        <hr noshade="noshade" size="1"/> ! sun 1.5

        Mark Reynolds added a comment -

        This issue has nothing to do with space WITHIN tags.

        Jesse Kuhnert added a comment -

        Well damn. Ok....


          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Mark Reynolds
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development