Tapestry
  1. Tapestry
  2. TAPESTRY-831

DataSqueezing strategy should be more helpful

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0.1
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      any

      Description

      When trying to persist a form field value that is an unserializable java object the error reported just says that no suitable strategy could be found. I think it would be nice if in addition to that it added a message to the effect that:

      This is sometimes caused by trying to persist form fields with objects that don't implement java.io.Serializable.

        Activity

        Jesse Kuhnert added a comment -

        Fixed by adding Serializable hint in error strings


          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Jesse Kuhnert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development