Tapestry
  1. Tapestry
  2. TAPESTRY-771

Dependencies are not loaded from Ibiblio when using Tapestry in a Maven 2 project

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 4.0
    • Fix Version/s: 4.1.1
    • Component/s: Build
    • Labels:
      None
    • Environment:
      Building a Tapestry project with Maven 2 (linux, JDK1.5, Tapestry 4.0-beta-13)

      Description

      When using Tapestry in a Maven 2 project, the dependencies are not automatically loaded, so you have to declare them all in the pom.xml, which sort of defeats the purpose of transitive dependency management . On Ibiblio (http://www.ibiblio.org/maven2/tapestry/tapestry/4.0-beta-13/), the tapestry-4.0-beta-13.pom looks like this:

      <project>
      <modelVersion>4.0.0</modelVersion>
      <groupId>tapestry</groupId>
      <artifactId>tapestry</artifactId>
      <version>4.0-beta-13</version>
      </project>

      I suspect it should look like this:

      <project>
      <modelVersion>4.0.0</modelVersion>
      <groupId>tapestry</groupId>
      <artifactId>tapestry</artifactId>
      <version>4.0-beta-13</version>
      <dependencies>
      <dependency>
      <groupId>commons-codec</groupId>
      <artifactId>commons-codec</artifactId>
      <version>1.3</version>
      </dependency>
      <dependency>
      <groupId>commons-fileupload</groupId>
      <artifactId>commons-fileupload</artifactId>
      <version>1.0</version>
      </dependency>
      <dependency>
      <groupId>commons-logging</groupId>
      <artifactId>commons-logging</artifactId>
      <version>1.0.4</version>
      </dependency>
      <dependency>
      <groupId>hivemind</groupId>
      <artifactId>hivemind</artifactId>
      <version>1.1</version>
      </dependency>
      <dependency>
      <groupId>hivemind</groupId>
      <artifactId>hivemind-lib</artifactId>
      <version>1.1</version>
      </dependency>
      <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
      </dependency>
      <dependency>
      <groupId>javassist</groupId>
      <artifactId>javassist</artifactId>
      <version>3.0</version>
      </dependency>
      <dependency>
      <groupId>oro</groupId>
      <artifactId>oro</artifactId>
      <version>2.0.8</version>
      </dependency>
      <dependency>
      <groupId>ognl</groupId>
      <artifactId>ognl</artifactId>
      <version>2.6.7</version>
      </dependency>
      </dependencies>
      </project>

        Activity

        Hide
        Andreas Andreou added a comment -
        Show
        Andreas Andreou added a comment - Use 4.0 or 4.0.1. Also see http://issues.apache.org/jira/browse/TAPESTRY-914

          People

          • Assignee:
            Unassigned
            Reporter:
            John Ferguson Smart
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development