Tapestry
  1. Tapestry
  2. TAPESTRY-2108

Tapestry.onDOMLoaded not working in konqueror

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.9
    • Fix Version/s: 5.0.11
    • Component/s: Core Components
    • Labels:
      None
    • Environment:
      Konqueror 3.5.8

      Description

      See prototype bug :
      Bug report : http://dev.rubyonrails.org/ticket/10532
      Patch : http://dev.rubyonrails.org/ticket/9838
      Tapestry : line 4822 in org.apache.tapestry.scriptaculous_1_8.prototype.js

      Not fixed on 1.6.2 available http://www.prototypejs.org... And looks like protoype does not want to support Konqueror

      Was : When using a palette component it's impossible to select an element if the brwoser is konqueror, neither by using the arrow or by double clicking an element.

        Issue Links

          Activity

          Mark Thomas made changes -
          Workflow Default workflow, editable Closed status [ 12569365 ] jira [ 12590622 ]
          Mark Thomas made changes -
          Workflow jira [ 12422506 ] Default workflow, editable Closed status [ 12569365 ]
          Howard M. Lewis Ship made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 5.0.11 [ 12312968 ]
          Resolution Fixed [ 1 ]
          Assignee Howard M. Lewis Ship [ hlship ]
          Landais Gabriel made changes -
          Summary Tapestry palette component not working in konqueror Tapestry.onDOMLoaded not working in konqueror
          Description When using a palette component it's impossible to select an element if the brwoser is konqueror, neither by using the arrow or by double clicking an element. See prototype bug :
           Bug report : http://dev.rubyonrails.org/ticket/10532
           Patch : http://dev.rubyonrails.org/ticket/9838
           Tapestry : line 4822 in org.apache.tapestry.scriptaculous_1_8.prototype.js

          Not fixed on 1.6.2 available http://www.prototypejs.org... And looks like protoype does not want to support Konqueror :(

          Was : When using a palette component it's impossible to select an element if the brwoser is konqueror, neither by using the arrow or by double clicking an element.
          Andreas Andreou made changes -
          Assignee Andreas Andreou [ andyhot ]
          Landais Gabriel made changes -
          Fix Version/s 4.1.1 [ 12312021 ]
          Affects Version/s 5.0.9 [ 12312930 ]
          Component/s Contrib [ 11281 ]
          Component/s Core Components [ 12311677 ]
          Environment Linux mandriva 2006, kde 3.5 Konqueror 3.5.8
          Landais Gabriel made changes -
          Field Original Value New Value
          Link This issue is a clone of TAPESTRY-987 [ TAPESTRY-987 ]
          Landais Gabriel created issue -

            People

            • Assignee:
              Howard M. Lewis Ship
              Reporter:
              Landais Gabriel
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development