Details

    • Type: Bug Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: 3.0
    • Fix Version/s: None
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      Operating System: Windows XP
      Platform: PC

      Description

      From IE6, clicking on the calendar icon results in the following error in the
      JavaScript console:

      Line: 941
      Char: 4
      Error: Object required
      Code: 0

      My page template uses DatePicker like this:

      <span jwcid="dueDate@DatePicker" value="ognl:dueDate"/>

      <property-specification name="dueDate" type="java.util.Date"/>

        Activity

        Ben Eng created issue -
        Erik Hatcher added a comment -

        Are you using the @Shell component around your pages?

        DatePicker is working just fine for me using Tapestry 3.0. We need more details. Please create a
        barebones page with only that component in a form and analyze the generated HTML to see what could
        be wrong.

        Django added a comment -

        I experienced the same problem and was able to narrow it down to an absolute
        positioned div:
        <div style="position:absolute; width:134px; height:23px; left: 10px; top:
        120px">
        Removing it solved the problem, but off course messed up the page.

        Ben Eng added a comment -

        Yes, I have a @Shell component.

        Whatever the problem is, it is IE-specific. Mozilla Firefox renders the
        @DatePicker just fine.

        Ben Eng added a comment -

        I just verified that it is indeed a surrounding <div> that is causing the
        problem in IE. It has the following style:

        { position: relative; left: 0px; top: 0px; height: 100%; overflow: auto; padding: 10px }
        Ben Eng added a comment -

        Appears to be similar (or duplicate of) 29059

        Django added a comment -

        It is a duplicate but I do not consider removing the div style to be a solution.

            • This bug has been marked as a duplicate of 29059 ***
        Serge Knystautas made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 30641 22713
        Mark Thomas made changes -
        Workflow jira [ 32708 ] Default workflow, editable Closed status [ 12567100 ]
        Mark Thomas made changes -
        Assignee Tapestry Developer List [ tapestry-dev@jakarta.apache.org ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12567100 ] jira [ 12589832 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Ben Eng
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development