Tapestry
  1. Tapestry
  2. TAPESTRY-1894

Redundant javascripts in the page when clientvalidate="false"

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 5.0.6
    • Fix Version/s: unspecified
    • Component/s: Core Components
    • Labels:
      None

      Description

      I have this form:

      <t:form t:id="myform" t:clientvalidation="false">
      <input t:type="textfield" t:id="comment" t:validate="required" />
      <input t:type="submit" name="Submit" t:id="Submit" value="Submit" /><br />
      <t:errors />
      </t:form>

      The rendered page still contains javascript even when clientvalidate="false", the only way to totally remove javascript from the page is, no t:validate parameter, actually those javascript is not being used when clientvalidation="false", I believe it's redundant, try to disable javascript in the browser and click submit, it still displays the correct error message same as when browser's javascript is enabled.

      Advantage of completely removing those script is, in a login form, user does not have to wait for the downloading of those scripts(around 200k, very noticeable in a slow connection)

        Activity

        Angelo Chen created issue -
        Howard M. Lewis Ship added a comment -

        Duplicate of TAPESTRY-1748.

        Howard M. Lewis Ship made changes -
        Field Original Value New Value
        Assignee Howard M. Lewis Ship [ hlship ]
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Duplicate [ 3 ]
        Howard M. Lewis Ship made changes -
        Fix Version/s unspecified [ 10790 ]
        Fix Version/s 5.0.7 [ 12312802 ]
        Mark Thomas made changes -
        Workflow jira [ 12416777 ] Default workflow, editable Closed status [ 12569304 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12569304 ] jira [ 12590557 ]

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Angelo Chen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development