Tapestry
  1. Tapestry
  2. TAPESTRY-1619

Add coercion from type [C ( simple char ) to type java.lang.Character

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 5.0.5
    • Fix Version/s: 5.0.6
    • Component/s: None
    • Labels:
      None

      Description

      Found while trying

      <span t:type="Loop" source="prop:all" value="prop:character">

      while having

      public char[] getAll

      {...}

      public char getCharacter()

      { ... }

        Activity

        Daniel Gredler added a comment -

        The fix to TAPESTRY-1702 seems to have fixed this issue. The following seems to work:

        private char c;
        public char[] getAll() { return new char[]

        { 'a', 'b', 'c' }

        ; }
        public void setCharacter(char c)

        { this.c = c; }

        public char getCharacter()

        { return this.c; }

        <span t:type="Loop" source="all" value="character">$

        {character}

        </span>

        Marking as a dupe of TAPESTRY-1702.


          People

          • Assignee:
            Daniel Gredler
            Reporter:
            Andreas Andreou
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development