Uploaded image for project: 'Tapestry'
  1. Tapestry
  2. TAPESTRY-1587

Script assets without a DTD result in a Server Error 500

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.2
    • Component/s: Framework, JavaScript
    • Labels:
      None
    • Environment:
      Windows Vista / Jetty

      Description

      The exception handler in Script.java (line 138-142) accesses the binding, resulting in an NPE:

      throw new ApplicationRuntimeException(ex.getMessage(), this, getBinding("script").getLocation(), ex);

      In the snippet above, "getBinding("script")" returns null. I'm not sure what the best way is to fix this, but the server crash right now is extremely ugly since there is NO indication what the problem is.

        Activity

        jkuhnert Jesse Kuhnert added a comment -

        This has been fixed in version 4.1.2 already. Thanks for posting the bug report either way though.


          People

          • Assignee:
            jkuhnert Jesse Kuhnert
            Reporter:
            mvonballmo Marco Von Ballmoos
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development