Uploaded image for project: 'Tapestry'
  1. Tapestry
  2. TAPESTRY-1573

JettyRunner seems to require Jetty 6.x jar but dependencies point to Jetty 5.x

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 5.0.4
    • Fix Version/s: None
    • Component/s: tapestry-test
    • Labels:
      None

      Description

      I get this expection when i run any test:

      java.lang.ClassNotFoundException: org.mortbay.jetty.servlet.DefaultServlet]
      at org.apache.tapestry.test.JettyRunner.createAndStart(JettyRunner.java:112)
      at org.apache.tapestry.test.JettyRunner.<init>(JettyRunner.java:67)
      at org.apache.tapestry.test.AbstractIntegrationTestSuite.setup(AbstractIntegrationTestSuite.java:160)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      After a little searching i found that org.mortbay.jetty.servlet.DefaultServlet is only in the Jetty 6.x jars. But the selenium 0.8.1 depends on Jetty 5.x.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              hpalma Hugo Palma
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: