Tapestry
  1. Tapestry
  2. TAPESTRY-1547

no equivalent of <inherited-binding> when using annotations

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.2
    • Fix Version/s: 4.1.5
    • Component/s: Annotations
    • Labels:
      None

      Description

      The followign workaround works in most cases:

      @Component(binding="element=element")
      public abstract Any getAny();

      I have found that in case of 'updateComponents' parameters (eg. DirectLink's) this doesn't work, so I have to fall back using XML specifications.

        Activity

        Norbert Sándor added a comment -

        Another problem:

        @Parameter
        public abstract Object getParameter();

        @Component(bindings="someParameter=parameter")
        public abstract SomeComponent getSomeComponent();

        In this case if "parameter" is not bound then the expression "parameter" would evaluate to null.
        If SomeComponent.someParameter has a default value then it is ignored and the null value is used instead.

        This forces the usage of a .jwc file and makes creating xml-less components impossible.

        Norbert Sándor added a comment -

        And of course this is not a bug but a feature request.


          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Norbert Sándor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development